Home Operation and Maintenance Safety How to perform route-map parsing

How to perform route-map parsing

May 23, 2023 pm 12:01 PM
route-map

1、route-map解析

How to perform route-map parsing

How to perform route-map parsing

How to perform route-map parsing

How to perform route-map parsing

How to perform route-map parsing

2、实验拓扑

How to perform route-map parsing

3、实验配置

R1配置

interface Serial0/0

 ip address 12.1.1.1 255.255.255.0

interface Serial0/1

 ip address 13.1.1.1 255.255.255.0

interface Serial0/2

 ip address 14.1.1.1 255.255.255.0

router eigrp 90

 redistribute ospf 110 metric 1500 100 255 1 1500

 network 14.1.1.0 0.0.0.255

 no auto-summary

router ospf 110

 router-id 1.1.1.1

 log-adjacency-changes

 redistribute rip subnets

 network 13.1.1.0 0.0.0.255 area 0

router rip

 version 2

 network 12.0.0.0

 no auto-summary

R2配置

interface Loopback0

 ip address 2.2.2.2 255.255.255.0

interface Loopback22

 ip address 22.22.22.22 255.255.255.0

interface Loopback222

 ip address 222.222.222.222 255.255.255.0

interface Serial0/0

 ip address 12.1.1.2 255.255.255.0

router rip

 version 2

 network 2.0.0.0

 network 22.0.0.0

 network 222.222.222.0

 network 12.0.0.0

 no auto-summary

R3配置

interface Loopback0

 ip address 3.3.3.3 255.255.255.0

interface Serial0/0

 ip address 13.1.1.3 255.255.255.0

router ospf 110

 router-id 3.3.3.3

 log-adjacency-changes

 network 3.3.3.0 0.0.0.255 area 0

 network 13.1.1.0 0.0.0.255 area 0

R4配置

interface Loopback0

 ip address 4.4.4.4 255.255.255.0

interface Serial0/0

 ip address 14.1.1.4 255.255.255.0

router eigrp 90

 network 4.4.4.0 0.0.0.255

 network 14.1.1.0 0.0.0.255

 no auto-summary

How to perform route-map parsing

此时R3学到4外部路由,我们希望作如下修改。

222.222.222.0/24    修改为E1

2.2.2.0/24          修改Default Seed Metrics为10

22.22.22.0/24       deny掉,permit any

R1配置

ip prefix-list 222 seq 5 permit 222.222.222.0/24

access-list 2 permit 2.2.2.0 0.0.0.255

access-list 22 permit 22.22.22.0 0.0.0.255

route-map RM permit 10

 match ip address prefix-list 222

 set metric-type type-1

route-map RM permit 20

 match ip address 2

 set metric 10

route-map RM deny 30

 match ip address 22

route-map RM permit 40

router ospf 110

 redistribute rip subnets route-map RM

How to perform route-map parsing

可以看到结果与我们的需求一致。

The above is the detailed content of How to perform route-map parsing. For more information, please follow other related articles on the PHP Chinese website!

Statement of this Website
The content of this article is voluntarily contributed by netizens, and the copyright belongs to the original author. This site does not assume corresponding legal responsibility. If you find any content suspected of plagiarism or infringement, please contact admin@php.cn

Hot AI Tools

Undresser.AI Undress

Undresser.AI Undress

AI-powered app for creating realistic nude photos

AI Clothes Remover

AI Clothes Remover

Online AI tool for removing clothes from photos.

Undress AI Tool

Undress AI Tool

Undress images for free

Clothoff.io

Clothoff.io

AI clothes remover

Video Face Swap

Video Face Swap

Swap faces in any video effortlessly with our completely free AI face swap tool!

Hot Tools

Notepad++7.3.1

Notepad++7.3.1

Easy-to-use and free code editor

SublimeText3 Chinese version

SublimeText3 Chinese version

Chinese version, very easy to use

Zend Studio 13.0.1

Zend Studio 13.0.1

Powerful PHP integrated development environment

Dreamweaver CS6

Dreamweaver CS6

Visual web development tools

SublimeText3 Mac version

SublimeText3 Mac version

God-level code editing software (SublimeText3)

Hot Topics

Java Tutorial
1655
14
PHP Tutorial
1252
29
C# Tutorial
1226
24