首页 >web前端 >前端问答 > 正文

vuejs支持ie678吗

原创2021-09-15 17:14:520583

vuejs不支持ie678,因为Vue.js使用了IE8及其以下版本不能模拟的ECMAScript5特性,例如“Object.defineProperty()”和“Promise”。

本教程操作环境:windows7系统、vue2.9.6版,DELL G3电脑。

vue支持 IE8及其以下版本,即不支持ie6、ie7、ie8。

那为什么呢?原因:

Vue 使用了 IE8及其以下版本无法模拟的 ECMAScript 5 特性。换句话说:Vue支持所有兼容 ECMAScript 5 的浏览器。

但具体是哪些特性呢?

Object.defineProperty()

该方法允许精确添加或修改对象的属性。一般情况下,我们为对象添加属性是通过赋值来创建并显示在属性枚举中(for…in 或 Object.keys 方法),但这种方式添加的属性值可以被改变,也可以被删除。而使用 Object.defineProperty() 则允许改变这些额外细节的默认设置。例如,默认情况下,使用 Object.defineProperty() 增加的属性值是不可改变的。

在 vue 源码中搜索 “Object.defineProperty” :

可以看到有 5 个匹配的地方,也就是说 vue 中有 5 处使用了 “Object.defineProperty()”。

搜索的版本是: Vue.js v1.0.26

Object.defineProperty()的浏览器支持情况:

可以看出支持情况是 IE9 及以上。

vue 官方有对这个的说明:
在这里插入图片描述

Promise

Vue需要Promise的支持,IE8同样不支持Promsie。

相关推荐:《vue.js教程

以上就是vuejs支持ie678吗的详细内容,更多请关注php中文网其它相关文章!

php中文网最新课程二维码

声明:本文原创发布php中文网,转载请注明出处,感谢您的尊重!如有疑问,请联系admin@php.cn处理

  • 相关标签:vuejs IE8
  • 相关文章

    相关视频


    网友评论

    文明上网理性发言,请遵守 新闻评论服务协议

    我要评论
  • 专题推荐

    作者信息
    推荐视频教程
  • vue 3.0全新实战课程(2021版)第一季vue 3.0全新实战课程(2021版)第一季
  • vue 3.0全新实战课程(2021版)第二季vue 3.0全新实战课程(2021版)第二季
  • VuePress: 30分钟制作一个Vue静态网站VuePress: 30分钟制作一个Vue静态网站
  • VuePress: Vue 官方静态网站生成器极速指南VuePress: Vue 官方静态网站生成器极速指南
  • Vue.js:纪录片Vue.js:纪录片
  • 视频教程分类