首页 >数据库 >phpMyAdmin > 正文

php利用composer安装phpmyadmin

转载2020-01-15 17:35:140711
下面由phpmyadmin教程栏目给大家介绍php利用composer安装phpmyadmin的方法,希望对需要的朋友有所帮助!

phpmyadmin是一个适合初学者使用的mysql的管理工具,历史悠久。

现在,利用composer可以轻易安装,步骤。

首先确保本机的mysqli插件已装好,

现在,假设我的本机的web文档根目录是

d:/workspace/t1/public

则cmd下,

cd d:/workspace/t1/public
composer create-project phpmyadmin/phpmyadmin

这时,会把最新的(当前是4.7.1版)phpmyadmin装在自己电脑上。

现在,进入该目录

把config.sample.inc.php复制一份,并命名为config.inc.php

然后把下面4行取消注释,并填写正确的值。

$cfg['Servers'][$i]['controlhost'] = '127.0.0.1'; // 域名
 $cfg['Servers'][$i]['controlport'] = '';         //如果数据库是3306,可不填
 $cfg['Servers'][$i]['controluser'] = 'root';     //数据库用户
 $cfg['Servers'][$i]['controlpass'] = 'root';     //数据库密码

这就已经装好了。

打开浏览器,输入

localhost/phpmyadmin/index.php
[img]http://dl2.iteye.com/upload/attachment/0125/9853/d07a4a8e-35e9-3a9e-b928-4df37e236ce5.png[/img]

上图中,输入数据库用户名和数据库密码即可登录。

如果总是出现下面这样的错误,其实是没关系的。不管它。

mysqli_real_connect(): Headers and client library minor version mismatch. Headers:50541 Library:50634

屏蔽此错误的方法:

修改\phpmyadmin\libraries\dbi\DBIMysqli.php

// 用这种变态的方法屏蔽错误
$err_level = error_reporting(0);
$return_value = mysqli_real_connect(
            $link,
            $host,
            $user,
            $password,
            '',
            $server['port'],
            $server['socket'],
            $client_flags
        );
error_reporting($err_level);

最后,其实通过web访问的方式,虽然方便,但是不安全,所以只建议放在本机,[b]不能放在生产服务器上[/b]。

以上就是php利用composer安装phpmyadmin的详细内容,更多请关注php中文网其它相关文章!

php中文网最新课程二维码
  • 相关标签:phpmyadmin
  • 本文转载于:csdn,如有侵犯,请联系a@php.cn删除
  • 相关文章

    相关视频


    网友评论

    文明上网理性发言,请遵守 新闻评论服务协议

    我要评论
  • 使yumphpmyadmin的方法:先remi源。
    下面由composer使教程栏目给大家介绍CI框架使composer的依赖包步骤与方法,希望对需要的朋友有所帮助!
    ​下面由composer教程栏目给大家介绍解决composerlaravel时要验证的问题的方法,希望对需要的朋友有所帮助!解决办法:填入你的 github 账号密码,或者更换另一个源...
    使yumphp的方法:1、添加php的yum软件仓库。2、使sudo yum install xxx命令php相关软件。
    下面由WordPress教程栏目给大家介绍百度快照变通下载 WordPress 插件的方法,希望对需要的朋友有所帮助!
    centos7下yum软件时出错了的解决方法是:1、查看网络配置文件ifcfg-ens33;2、修改网关;3、执行命令【service network restart】重启网络。
    Ubuntu中使apt-get指定php版本号的方法是:首先使【sudo apt-get install package=version】命令;然后指定包及版本;最后即可。
    Laravel Composer 来管理依赖。所以,在使 Laravel 之前,请确保你的机器上Composer
    Memcached下的PHP扩展使的方法:首先选择对应扩展包,上传PHP扩展库;然后解压编译;并在【php.ini】配置文件里开启;接着查看phpinfo里的显示;最后编辑测试文件。
    以及如何ComposerFastRoute和在php代码中使的示例。
    PHP SDK的方法:首先Composer;然后使命令“php composer.phar require qiniu/php-sdk”最新稳定版本的SDK即可。
    yii2.0程序的方法:首先下载composer程序;然后使composer self-update命令将composer更新为最新版;最后使composer create-project命令来
    windows下yii框架的方法:1、composer,配置php环境变量;2、通过windows的'cmd'命令进入dos命令窗口,从dos中进入网站根目录;3、使composer命令yii
    以下教程针对windows系统,示例系统使win7:下载composer包(群里),点击,其中出现 ‘composer choose the command-line php’要求进行选择时.
    composeryii报错的解决办法:首先使命令“composer clear-cache”清空缓存;然后设置可的镜像;接着通过命令“composer install”执行;最后在config
    下面由composer教程栏目给大家介绍composersymfony的方法,希望对需要的朋友有所帮助!
    composer查看已经的扩展包的方法:首先通过命令“composer show -i”查看已包的名称和版本信息;然后使命令“composer global show”查看全局的包名称和版本即可
    下面由composer使教程栏目给大家介绍Linux下composer的方法,希望对需要的朋友有所帮助!1. 官网直接下载;2. 全局;3. 测试。
    使composer create-project topthink/think testTG,来thinkphp5.
    laravelpredis的方法:首先“redis-server”;然后服务器开启“redis-server”;接着让指定的php来进行composer下载predis插件;最后在控制器中使即可

    专题推荐

    推荐视频教程
  • javascript初级视频教程javascript初级视频教程
  • jquery 基础视频教程jquery 基础视频教程
  • 视频教程分类