首页 >开发工具 >composer > 正文

用Composer安装特定版本的软件包

原创2021-06-04 14:17:490506
下面由composer教程栏目给大家介绍用Composer安装特定版本的软件包,希望对需要的朋友有所帮助!

这是一篇关于如何使用 Composer 安装特定版本软件包的简短快速文章

TL;DR 版本

composer require vendor/package:version
//Example
composer require laravel/passport:6.0

详细版

在终端导航到项目根目录,执行以下命令,使用 Composer 安装特定版本的包

假设您希望将 larvael/passport 包的 6.0.0 版安装到您的项目中,而不是安装最新版本。然后你应该执行以下命令

composer require laravel/passport:6.0.0

添加双引号以在版本号中使用插入符号或波浪号运算符。

例如

composer require middlewares/whoops "^0.4"

波浪号版本范围 (~) – ~1.2.3 相当于 >=1.2.3 <1.3.0

插入符号版本范围 (^) – ^1.2.3 相当于 >=1.2.3 <2.0.0

因此,使用波浪号,您将获得补丁的自动更新,但不会更新次要和主要版本。但是,如果您使用 Caret,您将获得补丁和次要版本,但不会获得主要(重大更改)版本。

Tilde Version 被认为是一种“更安全”的方法,但如果您使用可靠的依赖项(维护良好的库),则使用 Caret 版本应该不会有任何问题(因为小的更改不应该破坏更改。

本文系英文直译,若有疑问,请访问原文:https://5balloons.info/install-specific-version-of-package-using-composer/

以上就是用Composer安装特定版本的软件包的详细内容,更多请关注php中文网其它相关文章!

php中文网最新课程二维码

声明:本文原创发布php中文网,转载请注明出处,感谢您的尊重!如有疑问,请联系admin@php.cn处理

  • 相关标签:Composer
  • 相关文章

    相关视频


    网友评论

    文明上网理性发言,请遵守 新闻评论服务协议

    我要评论
  • 专题推荐

    推荐视频教程
  • PHP Composer 视频教程PHP Composer 视频教程
  • 轻松掌握Composer软件依赖工具(玉女心经版)轻松掌握Composer软件依赖工具(玉女心经版)
  • 视频教程分类