首页 >开发工具 >composer > 正文

wamp环境下运行composer的坑

转载2019-09-09 13:43:410775
phpstudy集成环境下载
下面由composer使用教程栏目为大家介绍wamp环境下运行composer的坑的解决办法,希望对需要的朋友有所帮助。

今天在用composer安装laravel时报错

The openssl extension is required for SSL/TLS protection but is not availab le. If you can not enable the openssl extension, you can disable this error , at your own risk, by setting the 'disable-tls' option to true.

网上说是OpenSSL没有打开的问题,打开php.ini,启用插件并设置相应的证书,然后重启Apache。

理论上来说,走到这一步应该没什么问题了,phpinfo();里也有OpenSSL的扩展,但是报错依旧。

研究后发现,composer判断OpenSSL的依据是:当前环境变量下的php目录下的php.ini文件,但是wamp下php.ini文件实际上对应的是php目录下的phpForApache.ini而不是php.ini,所以把phpForApache.ini里的内容全部复制到php.ini,再次运行composer install就没有报错了。

以上就是wamp环境下运行composer的坑的详细内容,更多请关注php中文网其它相关文章!

php中文网最新课程二维码
  • 相关标签:Composer
  • 本文转载于:segmentfault,如有侵犯,请联系a@php.cn删除
  • 相关文章

    相关视频


    网友评论

    文明上网理性发言,请遵守 新闻评论服务协议

    我要评论
  • 专题推荐

    推荐视频教程
  • PHP Composer 视频教程PHP Composer 视频教程
  • 视频教程分类