首页 >开发工具 >composer > 正文

解决composer.phar安装问题

原创2019-09-06 13:46:5601148
第九期线上培训班
下面由composer使用教程栏目为大家介绍composer.phar安装问题的解决办法,希望对需要的朋友有所帮助!

问题:

下载composer.phar文件根据官方教程安装完毕,运行composer指令时报错:PHP Fatal error: Uncaught exception 'PharException' with message 'phar...

解决:

可能是composer.phar文件损坏。重新下载最新文件快照https://getcomposer.org/composer.phar

注:

Composer 是 PHP 的一个依赖管理工具。我们可以在项目中声明所依赖的外部工具库,Composer 会帮你安装这些依赖的库文件,有了它,我们就可以很轻松的使用一个命令将其他人的优秀代码引用到我们的项目中来。

Composer 默认情况下不是全局安装,而是基于指定的项目的某个目录中(例如 vendor)进行安装。

Composer 需要 PHP 5.3.2+ 以上版本,且需要开启 openssl。

Composer 可运行在 Windows 、 Linux 以及 OSX 平台上。

以上就是解决composer.phar安装问题的详细内容,更多请关注php中文网其它相关文章!

php中文网最新课程二维码
  • 相关标签:composer
  • 本文原创发布php中文网,转载请注明出处,感谢您的尊重!
  • 相关文章

    相关视频


    网友评论

    文明上网理性发言,请遵守 新闻评论服务协议

    我要评论
  • 专题推荐

    推荐视频教程
  • PHP Composer 视频教程PHP Composer 视频教程
  • 视频教程分类
    第九期线上培训班