首页 >后端开发 >Python教程 > 正文

tensorflow用python哪个版本更好?

原创2019-06-15 11:04:5801485
phpstudy集成环境下载
tensorflow用python哪个版本?

相关推荐:《python视频

一、安装anaconda

tensorflow是基于python脚本语言的,因此需要安装python, 当然还需要安装numpy、scipy、six、matplotlib等几十个扩展包。如果一个个安装,装到啥时候去?(我曾经光安装scipy就装了一天。。。)

不过现在有了集成环境anaconda,安装就方便了。python的大部分扩展包, 都集成在anaconda里面了,因此只需要装这一个东西就行了。

先到https://www.continuum.io/downloads 下载anaconda, 现在的版本有python2.7版本和python3.5版本,下载好对应版本、对应系统的anaconda,它实际上是一个sh脚本文件,大约300M-400M左右。推荐使用linux版的python 2.7版本,因为tensorflow中的有些东西不支持python3.5(如cPickle)。

222.png

下载成功后,在终端执行(2.7版本):

# bash Anaconda2-4.1.1-Linux-x86_64.sh

或者3.5 版本:

# bash Anaconda3-4.1.1-Linux-x86_64.sh

在安装的过程中,会问你安装路径,直接回车默认就可以了。有个地方问你是否将anaconda安装路径加入到环境变量(.bashrc)中,这个一定要输入yes

安装成功后,会有当前用户根目录下生成一个anaconda2的文件夹,里面就是安装好的内容。在终端可以输入

conda info 来查询安装信息

输入conda list 可以查询你现在安装了哪些库,常用的python, numpy, scipy名列其中。如果你还有什么包没有安装上,可以运行

conda install *** 来进行安装(***代表包名称),如果某个包版本不是最新的,运行 conda update *** 就可以了。

二、安装tensorflow

先在终端执行:

111.png

anaconda search -t conda tensorflow

搜索一下有哪些tensorflow安装包,通过查看版本,选择最高的版本安装。比如我看到是0.10.0rc0版本是最高的,如下图:

因此,执行下面代码来查看详细信息:

anaconda show jjhelmus/tensorflow

它就会告诉你,怎么来安装这个包,在终端执行:

conda install --channel https://conda.anaconda.org/jjhelmus tensorflow

然后输入"y",进行安装。

三、调试

安装成功与否,我们可以测试一下。

在终端输入python,进入python编译环境,然后输入:

import tensorflow as tf

引包tensorflow包,如果没有报错,则安装成功,否则就有问题。

然后可以输入

tf.__version__tf.__path__

查看tensorflow的安装版本和安装路径(左右各两根下横线)。

以上就是tensorflow用python哪个版本更好?的详细内容,更多请关注php中文网其它相关文章!

php中文网最新课程二维码
  • 相关标签:tensorflow python
  • 本文原创发布php中文网,转载请注明出处,感谢您的尊重!
  • 相关文章

    相关视频


    网友评论

    文明上网理性发言,请遵守 新闻评论服务协议

    我要评论
  • 专题推荐

    作者信息
    推荐视频教程
  • python教程之Django视频教程python教程之Django视频教程
  • python编程入门系列图文教程python编程入门系列图文教程
  • 零基础入门Python项目实战零基础入门Python项目实战
  • 视频教程分类