phpstudy多版本php共存配置方法【fcgid脚本映射】
作者: default|标签:phpstudy 多版本php共存|2017-7-13 14:43
相信大家对phpStudy都不陌生,你也可以使用2017年php中文网最新推出的“程序员工具箱php集成环境http://tool.php.cn”,

下面以phpstudy为例讲下如何配置多版本并存的pphp开发环境。

你可能会因为多个项目需要的php版本不同,程序无法兼容不得不来回切换php版本而烦恼,在此提供本人多年的经验总结,希望能帮到迷茫中的你。。。。

三步就能实现版本共存,如下:

步骤一、切换php版本



步骤二、找到Include conf/extra/httpd-mpm.conf将下面一行改为:

LoadModule fcgid_module modules/mod_fcgid.so
AddHandler fcgid-script .fcgi .php
Include conf/extra/httpd-php-fcgid53.conf
#httpd-php-sapi52.conf



步骤三、虚拟主机配置,添加:

FcgidInitialEnv PHPRC "D:/phpStudy/php56n/"
FcgidWrapper "D:/phpStudy/php56n/php-cgi.exe" .php


其中“D:/phpStudy/”换成你自己的phpstudy安装路径。

是不是已经配置成功了,敲一段标准的 phpinfo(); 试试吧


本文由php中文网整理,

原文地址: http://www.php.cn/php-weizijiaocheng-374013.html

不喜勿喷~~~

以上就是phpstudy多版本php共存配置方法【fcgid脚本映射】的详细内容,更多请关注php中文网其它相关文章!

14
点赞
收藏
分享:
0/300
首页上一页1下一页尾页